Jellybean(android 4.1)/OSC feedback

Home Forums Control Jellybean(android 4.1)/OSC feedback

This topic contains 6 replies, has 5 voices, and was last updated by  henderson 4 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #93200

    nonghost
    Member

    Using a nexus 7 and not getting the OSC routing back to the interfaces.
    Still works on an old tablet though.

     

    Anyone got this to work on Jellybean… a.k.a Android 4.1?

    #93201

    nico
    Member

    hi,

    I’ve a SGS2,

    OSC feedback is working but not as well as expected…

    it works after a reboot, but if I loose wifi connection, it won’t work anymore till the next reboot.

     

    ++

    #93229

    Mario Mey
    Member

    I have the same BIG problem: http://charlie-roberts.com/Control/?topic=android-ics-doesnt-receive-all-osc-messages

    I’ve been using an old cheap Tablet with Android 2.1. It can send and receive OSC messages. Now, I’ve installed Control by GooglePlay in Android 4.0.3 (Galaxy Tab 2) and, with the same interface, it doen’t receive OSC messages. I can’t change any value.

    The strange thing is that it receives using a default interface, like “DJ”. I can control the volume, for example.

    From PureData, I tried sending the default “send /volume 0.5″ for example and “send /control/runScript volume.setValue(0.5)”, both with MrPeach-OSC. None of them worked.

    I have an old cheap Tablet with Android 2.1 and a Samsung Galaxy Tab 2 10.1, Android 4.0.3. The update is that not all the messages are lost. Some of them arrives…

    Charlie told me that develop version should work… but it doesn’t. I have more issues with that version. For the moment… there’s no way to do what I want in my Android. TouchOSC editor doesn’t work in Android and its hack doesn’t allow labels, that they are very important for me.

    Chalie, we need you!!!

    #93258

    E-Fir
    Member

    I have the same issue

    Tested on Android 2.3.4 and 4.0.4

    `netstat` tolds me that only udp6 port listening

    but it seems udp4 needed for OSC

    #93262

    E-Fir
    Member

    I patched Control from master branch: now it’s listen TCP connection instead of UDP

    Because of fixed connection we need send packet size first before packet content. Packets size is int32 number.

    https://github.com/E-Fir/Control/blob/master/Android/Control/Control.apk?raw=true

    It’s solves issues for me.

    #93264

    nonghost
    Member

    could you go into a little more detail in how you got your apk to work?

    “Because of fixed connection we need send packet size first before packet content. Packets size is int32 number”

     

     

    sorry I don’t understand what you mean by this.

    #93320

    henderson
    Member

    That might because of the updates for Android, try to use the rooted one. I have seen same but working with my friends Android device but it is 4.0 OS version.

    Regards,
    Henderson for http://www.kekacase.com/design-your-own/phone-cases.html

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

This work is licensed under GPL - 2009 | Powered by Wordpress using a heavily modified version of the theme aav1